summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-03 22:14:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-04 01:51:21 +0200
commit0f08917df3f35ba5b54361c4b27255304102ced4 (patch)
treef8c54359d1cf5ef7ef9e8bdf6bfda3a5ee44c954 /gnu
parent20f8d1dd78c67872a670bb98cf8e76cef74baa64 (diff)
downloadguix-0f08917df3f35ba5b54361c4b27255304102ced4.tar.gz
gnu: zerofree: Use ‘modify-phases’ syntax.
* gnu/packages/linux.scm (zerofree)[arguments]: Use ‘modify-phases’.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a7d24da7a1..76f97f7e8a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -833,19 +833,21 @@ ext3 or ext4 partition.")
                 "1xncw3dn2cp922ly42m96p6fh7jv8ysg6bwqbk5xvw701f3dmkrs"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-replace
-                 'install
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   (let* ((out (assoc-ref outputs "out"))
-                          (bin (string-append out "/bin")))
-                     (mkdir-p bin)
-                     (copy-file "zerofree"
-                                (string-append bin "/zerofree"))
-                     (chmod (string-append bin "/zerofree")
-                            #o555)
-                     #t))
-                 (alist-delete 'configure %standard-phases))
-       #:tests? #f))                              ;no tests
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure)            ; no configure script
+         (replace 'install
+           ;; The Makefile lacks an ‘install’ target.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
+               (mkdir-p bin)
+               (copy-file "zerofree"
+                          (string-append bin "/zerofree"))
+               (chmod (string-append bin "/zerofree")
+                      #o555)
+               #t))))
+       #:tests? #f))                    ; no tests
     (inputs `(("libext2fs" ,e2fsprogs)))
     (synopsis "Zero non-allocated regions in ext2/ext3/ext4 file systems")
     (description