summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-14 16:23:11 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 19:01:16 -0800
commit97e32948ea59bcc48c2e2595626b87bc463144ad (patch)
tree794f947ac33a90f063a3e0a9c3748a0f49cab909 /gnu
parent22df6419f86929f34be561e958136950759710a6 (diff)
downloadguix-97e32948ea59bcc48c2e2595626b87bc463144ad.tar.gz
gnu: Add python-translitcodec.
* gnu/packages/python.scm (python-translitcodec, python2-translitcodec):
  New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 81b4248963..bb800e793f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8047,3 +8047,34 @@ synchronously (wait until ready).")
                        ("python2-unittest2" ,python2-unittest2)
                        ("python2-mock" ,python2-mock)
                        ,@(package-native-inputs celery))))))
+
+(define-public python-translitcodec
+  (package
+    (name "python-translitcodec")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "translitcodec" version))
+       (sha256
+        (base32
+         "10x6pvblkzky1zhjs8nmx64nb9jdzxad4bxhq4iwv0j4z2aqjnki"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))  ; no tests provided
+    (home-page
+     "https://github.com/claudep/translitcodec")
+    (synopsis
+     "Unicode to 8-bit charset transliteration codec")
+    (description
+     "This package contains codecs for transliterating ISO 10646 texts into
+best-effort representations using smaller coded character sets (ASCII,
+ISO 8859, etc.).")
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-translitcodec))))))
+
+(define-public python2-translitcodec
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-translitcodec)))
+    (native-inputs `(("python2-setuptools" ,python2-setuptools)))))