summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym+a@scratchpost.org>2016-07-09 14:48:32 +0200
committerLeo Famulari <leo@famulari.name>2016-07-09 14:12:14 -0400
commita502dfbf4ccd31121cb5fc0b13a46e25c99829b0 (patch)
tree25e2d39924a6e35e15af28921eabd094acbdc8b9 /gnu
parentec2a67de8813dc7ea31c9825c6dfe6f27ad86344 (diff)
downloadguix-a502dfbf4ccd31121cb5fc0b13a46e25c99829b0.tar.gz
gnu: Add python-jedi.
* gnu/packages/python.scm (python-jedi, python2-jedi): New variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ccbed0f24e..fb86290206 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9724,3 +9724,31 @@ characters, mouse support, and auto suggestions.")
       (native-inputs
        `(("python2-setuptools" ,python2-setuptools)
          ,@(package-native-inputs base))))))
+
+(define-public python-jedi
+  (package
+    (name "python-jedi")
+    (version "0.9.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "jedi" version))
+        (sha256
+          (base32
+            "0c8x962ynpx001fdvp07m2q5jk4igkxbj3rmnydavphvlgxijk1v"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/davidhalter/jedi")
+    (synopsis
+      "Autocompletion for Python that can be used for text editors")
+    (description
+      "Jedi is an autocompletion tool for Python that can be used for text editors.")
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-jedi))))))
+
+(define-public python2-jedi
+  (let ((base (package-with-python2 (strip-python2-variant python-jedi))))
+    (package
+      (inherit base)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs base))))))