summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-05 18:45:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-06 15:02:22 +0100
commit0faddfc392a62c4b5b4e68487d1835ab1aeab858 (patch)
treee62cce76dc79e768db0221934c2f26f638a50e0d /gnu
parentd4846779715ff77ccb35476a669bda34a291a1ab (diff)
downloadguix-0faddfc392a62c4b5b4e68487d1835ab1aeab858.tar.gz
gnu: ghc-aws: Update to 0.18.
* gnu/packages/haskell.scm (ghc-aws): Update to 0.18.
[inputs]: Replace ghc-cryptohash with ghc-cryptonite.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 66ccbae7f4..4d1aabff0b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7985,14 +7985,14 @@ as well as a convenient Conduit module.")
 (define-public ghc-aws
   (package
     (name "ghc-aws")
-    (version "0.17.1")
+    (version "0.18")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://hackage.haskell.org/package/"
                            "aws-" version "/aws-" version ".tar.gz"))
        (sha256 (base32
-                "1q4qh58vj8447a4fl88n3nkpdc4yv293qsh02w6zvszd6ch61yh7"))))
+                "0h7473wkvc5xjzx5fd5k5fp70rjq5gqmn1cpy95mswvvfsq3irxj"))))
     (build-system haskell-build-system)
     (arguments `(#:tests? #f)) ; Tests require AWS credentials.
     (inputs
@@ -8006,7 +8006,7 @@ as well as a convenient Conduit module.")
        ("ghc-cereal" ,ghc-cereal)
        ("ghc-conduit" ,ghc-conduit)
        ("ghc-conduit-extra" ,ghc-conduit-extra)
-       ("ghc-cryptohash" ,ghc-cryptohash)
+       ("ghc-cryptonite" ,ghc-cryptonite)
        ("ghc-data-default" ,ghc-data-default)
        ("ghc-http-conduit" ,ghc-http-conduit)
        ("ghc-http-types" ,ghc-http-types)