summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-14 03:32:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-15 03:36:35 +0200
commit1d7cc6841e6a997a38acb6421e0592ab5b4749df (patch)
tree5e250b1320059170755330e542f6e96ac51500a3 /gnu
parent9e9e5d5a269f32fab596c83451824a50dbc2b62d (diff)
downloadguix-1d7cc6841e6a997a38acb6421e0592ab5b4749df.tar.gz
gnu: coq: INVOKE.
* gnu/packages/ocaml.scm (coq)[arguments]: Substitute INVOKE for
SYSTEM*.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f21c2b2610..9e73eab1ea 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -486,16 +486,16 @@ written in Objective Caml.")
              (let* ((out (assoc-ref outputs "out"))
                     (mandir (string-append out "/share/man"))
                     (browser "icecat -remote \"OpenURL(%s,new-tab)\""))
-               (zero? (system* "./configure"
-                               "-prefix" out
-                               "-mandir" mandir
-                               "-browser" browser
-                               "-coqide" "opt")))))
+               (invoke "./configure"
+                       "-prefix" out
+                       "-mandir" mandir
+                       "-browser" browser
+                       "-coqide" "opt"))))
          (replace 'build
            (lambda _
-             (zero? (system* "make" "-j" (number->string
-                                          (parallel-job-count))
-                             "world"))))
+             (invoke "make"
+                     "-j" (number->string (parallel-job-count))
+                     "world")))
          (delete 'check)
          (add-after 'install 'check
            (lambda _
@@ -505,7 +505,7 @@ written in Objective Caml.")
                (delete-file-recursively "coq-makefile/timing")
                ;; This one fails because we didn't build coqtop.byte.
                (delete-file-recursively "coq-makefile/findlib-package")
-               (zero? (system* "make"))))))))
+               (invoke "make")))))))
     (home-page "https://coq.inria.fr")
     (synopsis "Proof assistant for higher-order logic")
     (description