summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-07 10:55:47 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-07 11:49:48 +0200
commit309e523e8f85e97eca07bc16721235be5ba0c2c3 (patch)
tree7743c7287290d7640054a104752b0e1f1deda860 /gnu
parent268ad34e0eadf8a015798b5c5587aad65b9f3a61 (diff)
downloadguix-309e523e8f85e97eca07bc16721235be5ba0c2c3.tar.gz
gnu: rottlog: Adjust the default 'weekly' config.
* gnu/packages/admin.scm (rottlog)[arguments]: Add 'tweak-rc-weekly'
phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f64cbce8e8..4e31b7c431 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -747,6 +747,15 @@ over ssh connections.")
                         (("packdir=\"\"")
                          "packdir=\"/var/log\""))
                       #t))
+                  (add-before 'install 'tweak-rc-weekly
+                    (lambda _
+                      (substitute* "rc/weekly"
+                        (("/bin/kill")
+                         (which "kill"))
+                        (("syslogd\\.pid")
+                         ;; The file is called 'syslog.pid' (no 'd').
+                         "syslog.pid"))
+                      #t))
                   (add-after 'install 'install-info
                     (lambda _
                       (zero? (system* "make" "install-info")))))))