summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-27 20:10:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-27 20:20:05 +0200
commit81d95a121aa2c73c72f26266c2971dc398380d55 (patch)
tree466379079c120f9e0ae2db00ab2366d97c08e224 /gnu
parent1e4063010d13249df94483e57d410fcc2965d6f5 (diff)
downloadguix-81d95a121aa2c73c72f26266c2971dc398380d55.tar.gz
gnu: corkscrew: Install the README file.
* gnu/packages/ssh.scm (corkscrew)[arguments]: Add a very basic
‘install-documentation’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index b5c73ea85e..4ac9a75c71 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -290,7 +291,13 @@ libssh library.")
                (setenv "CONFIG_SHELL" bash)
                (zero? (apply system* bash
                              (string-append "." "/configure")
-                             flags))))))))
+                             flags)))))
+         (add-after 'install 'install-documentation
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (string-append out "/share/doc/corkscrew")))
+               (install-file "README" doc)
+               #t))))))
     (home-page "http://www.agroman.net/corkscrew")
     (synopsis "SSH tunneling through HTTP(S) proxies")
     (description