summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-12 23:07:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-12 23:35:19 +0100
commitcad6fb2dec67e41498ee4cf9026ea5d12d8050e6 (patch)
tree1ab8e57a7ba46ea1945740d5251b4db43f4db07e /gnu
parent45dcd7dcfd1dcfa7cacd0e7d996bc5fa04891fed (diff)
downloadguix-cad6fb2dec67e41498ee4cf9026ea5d12d8050e6.tar.gz
gnu: Add r-plgem.
* gnu/packages/bioconductor.scm (r-plgem): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 06dc258005..0ded2a7b67 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -852,6 +852,31 @@ information.")
 in omics data.")
     (license license:gpl2+)))
 
+(define-public r-plgem
+  (package
+    (name "r-plgem")
+    (version "1.54.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "plgem" version))
+       (sha256
+        (base32
+         "1330635db3p8xm5y8fwrk1l37r6bgypsq70s3rx954i775zp6szg"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-mass" ,r-mass)))
+    (home-page "http://www.genopolis.it")
+    (synopsis "Detect differential expression in microarray and proteomics datasets")
+    (description
+     "The Power Law Global Error Model (PLGEM) has been shown to faithfully
+model the variance-versus-mean dependence that exists in a variety of
+genome-wide datasets, including microarray and proteomics data.  The use of
+PLGEM has been shown to improve the detection of differentially expressed
+genes or proteins in these datasets.")
+    (license license:gpl2)))
+
 (define-public r-inspect
   (package
     (name "r-inspect")