summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-26 12:44:09 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-26 13:31:16 +0200
commit05e3ed302f5a4dd611daf39c79e5e50502455b2d (patch)
tree4f255016b528014832aa8237ef86470d415a454e /gnu
parent30d0f7fa8f50b3a0a56573997b5bac180691a424 (diff)
downloadguix-05e3ed302f5a4dd611daf39c79e5e50502455b2d.tar.gz
gnu: tpacpi-bat: Adjust for Guile 3.0.
* gnu/packages/linux.scm (tpacpi-bat)[arguments]: Provide explicit destination
in calls to FORMAT.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9a8bbc78d8..12cb39ff9b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4717,11 +4717,11 @@ from userspace.")
            (lambda _
              (substitute* "tpacpi-bat"
                (("cat ")
-                (format "~a " (which "cat")))
+                (format #f "~a " (which "cat")))
                ;; tpacpi-bat modprobes the acpi_call kernel module if it's not
                ;; loaded.  That's the administrator's prerogative; disable it.
                (("system \"(modprobe .*)\"" _ match)
-                (format "die \"Please run ‘~a’ first.\\n\"" match)))
+                (format #f "die \"Please run ‘~a’ first.\\n\"" match)))
              #t))
          (delete 'configure)            ; nothing to configure
          (delete 'build)                ; nothing to build