summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-30 15:51:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-30 15:51:34 +0200
commit0b2883e1f61a5e29068c1eaa6d74dd1eb1f26049 (patch)
treebc6386e5bcfa481774f2f290da7c6fdec8e82fde /gnu
parentc4a5ce4648f9b5b69849b9d6b1d63367f5ce7aa0 (diff)
downloadguix-0b2883e1f61a5e29068c1eaa6d74dd1eb1f26049.tar.gz
gnu: Add r-grr.
* gnu/packages/cran.scm (r-grr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2980020c6f..0f77cde5ae 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -118,6 +118,26 @@ experiment that allows a generic to warn if any arguments passed in @code{...}
 are not used.")
     (license license:gpl3)))
 
+(define-public r-grr
+  (package
+    (name "r-grr")
+    (version "0.9.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "grr" version))
+       (sha256
+        (base32
+         "0arbcgrvhkwb5xk4nry1ffg2qj0v8ivhjghdr505ib4357g0c9i9"))))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/grr")
+    (synopsis "Alternative implementations of base R functions")
+    (description
+     "This package provides alternative implementations of some base R
+functions, including @code{sort}, @code{order}, and @code{match}.  The
+functions are simplified but can be faster or have other advantages.")
+    (license license:gpl3)))
+
 (define-public r-sys
   (package
     (name "r-sys")