summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-03-09 14:44:10 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-03-09 15:21:46 +0100
commit133de9ab38fef2f6edbff2fded361882f4916b6d (patch)
tree025eb0e25447bd2cd68393e8043037f37378e65d /gnu
parente8906d86ee08bbc41d91b2b11c2b2630d7f75f18 (diff)
downloadguix-133de9ab38fef2f6edbff2fded361882f4916b6d.tar.gz
gnu: Add readosm.
* gnu/packages/geo.scm (readosm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/geo.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 147a39ada7..6c6d7cf698 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1460,3 +1460,27 @@ archive all the GPS recordings of your past trips.  It is the successor of the
 QLandkarte GT application.")
     (home-page "https://github.com/Maproom/qmapshack/wiki")
     (license license:gpl3+)))
+
+(define-public readosm
+  (package
+    (name "readosm")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.gaia-gis.it/gaia-sins/"
+                           "readosm-" version ".tar.gz"))
+       (sha256
+        (base32 "1v20pnda67imjd70fn0zw30aar525xicy3d3v49md5cvqklws265"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("expat" ,expat)
+       ("zlib" ,zlib)))
+    (synopsis "Data extractor for OpenStreetMap files")
+    (description
+     "ReadOSM is a library to extract valid data from within an OpenStreetMap
+input file (in @code{.osm} or @code{.osm.pbf} format).")
+    (home-page "https://www.gaia-gis.it/fossil/readosm/index")
+    (license (list license:gpl2+
+                   license:lgpl2.1+
+                   license:mpl1.1))))