summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-02-07 22:05:19 -0600
committerLudovic Courtès <ludo@gnu.org>2019-02-12 23:30:16 +0100
commit2c880ef4e542c0d6aead79f740e140e45f47a855 (patch)
tree023c4c78575734f37600cb887433f19f76ad93fc /gnu
parentafb2971506d2342d27d4876d8a75f4ffa7e57462 (diff)
downloadguix-2c880ef4e542c0d6aead79f740e140e45f47a855.tar.gz
gnu: Add python-rope.
* gnu/packages/python-xyz.scm (python-rope): New variable.

Co-authored-by: Brett Gilio <brettg@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac22a69d80..0ba9f5266d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8859,6 +8859,16 @@ and parameters in Python 2 source code.  These refactorings can also be applied
 to occurrences in strings and comments.")
     (license license:gpl2)))
 
+(define-public python-rope
+  (package
+    (inherit python2-rope)
+    (name "python-rope")
+    (arguments `(#:python ,python-wrapper
+                 ;; XXX: Only partial python3 support, results in some failing
+                 ;; tests: <https://github.com/python-rope/rope/issues/247>.
+                 #:tests? #f))
+    (properties `((python2-variant . ,(delay python2-rope))))))
+
 (define-public python-py3status
   (package
     (name "python-py3status")