summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-24 12:13:37 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:06 -0400
commit2cdfaa026369d0dfc5760423ecffe27deb97c2d5 (patch)
tree0699333941acc4c7af467c5aaef4c1b40c743ff7 /gnu
parenteebf6380a49864dab520d75d2acc2a32c37fe1f6 (diff)
downloadguix-2cdfaa026369d0dfc5760423ecffe27deb97c2d5.tar.gz
gnu: go-github-com-prometheus-procfs: Update to 0.0.3.
* gnu/packages/syncthing.scm (go-github-com-prometheus-procfs): Update
to 0.0.3.
[arguments]: Skip the tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c11f0ad92c..1f10c02555 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -999,28 +999,29 @@ implementation.")
       (license asl2.0))))
 
 (define-public go-github-com-prometheus-procfs
-  (let ((commit "b15cd069a83443be3154b719d0cc9fe8117f09fb")
-        (revision "0"))
     (package
       (name "go-github-com-prometheus-procfs")
-      (version (git-version "0.0.0" revision commit))
+      (version "0.0.3")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
                        (url "https://github.com/prometheus/procfs.git")
-                       (commit commit)))
+                       (commit (string-append "v" version))))
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1cr45wg2m40bj2za8f32mq09rjlcnk5kfam0h0hr8wcb015k4wxj"))))
+                  "18c4m795fwng8f8qa395f3crvamlbk5y5afk8b5rzyisnmjq774y"))))
       (build-system go-build-system)
       (arguments
-       '(#:import-path "github.com/prometheus/procfs"))
+       '(#:import-path "github.com/prometheus/procfs"
+         ;; The tests require Go modules, which are not yet supported in Guix's
+         ;; Go build system.
+         #:tests? #f))
       (synopsis "Go library for reading @file{/proc}")
       (description "The @code{procfs} Go package provides functions to retrieve
 system, kernel, and process metrics from the @file{/proc} pseudo file system.")
       (home-page "https://github.com/prometheus/procfs")
-      (license asl2.0))))
+      (license asl2.0)))
 
 (define-public go-github-com-client-golang-prometheus-promhttp
     (package