summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPjotr Prins <pjotr.public12@thebird.nl>2015-09-14 16:32:27 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-14 11:36:30 -0400
commitb429c4fbb06299ce10ecc113a7818bf777c63a6e (patch)
tree0737210854c2c375108547668d9a03942218ceaf /gnu
parent239db054a731a8e35ab239a025219a16bba2deb3 (diff)
downloadguix-b429c4fbb06299ce10ecc113a7818bf777c63a6e.tar.gz
gnu: Add bio-locus.
* gnu/packages/bioinformatics.scm (bio-locus): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 03eb2dfe30..c4ba0e082f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2616,3 +2616,27 @@ data in the form of VCF files.")
     ;; The license is declared as LGPLv3 in the README and
     ;; at http://vcftools.sourceforge.net/license.html
     (license license:lgpl3)))
+
+(define-public bio-locus
+  (package
+    (name "bio-locus")
+    (version "0.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "bio-locus" version))
+       (sha256
+        (base32
+         "02vmrxyimkj9sahsp4zhfhnmbvz6dbbqz1y01vglf8cbwvkajfl0"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-rspec" ,ruby-rspec)))
+    (synopsis "Tool for fast querying of genome locations")
+    (description
+     "Bio-locus is a tabix-like tool for fast querying of genome
+locations.  Many file formats in bioinformatics contain records that
+start with a chromosome name and a position for a SNP, or a start-end
+position for indels.  Bio-locus allows users to store this chr+pos or
+chr+pos+alt information in a fast database.")
+    (home-page "https://github.com/pjotrp/bio-locus")
+    (license license:expat)))