summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-06-02 22:06:39 -0500
committerBen Woodcroft <donttrustben@gmail.com>2017-06-02 22:59:03 -0500
commit3fd577e3c51577403f5e8b7d77286f9ab72581ab (patch)
tree6e8bfa23f46de49ab3706d64f354bdae3437a38e /gnu
parentfc29d5e61b5d00004ecb8c53a2a19f64f7f129f2 (diff)
downloadguix-3fd577e3c51577403f5e8b7d77286f9ab72581ab.tar.gz
gnu: ruby-gem-hadar: Update to 1.9.1.
* gnu/packages/ruby.scm (ruby-gem-hadar): Update to 1.9.1.
[propagated-inputs]: Remove ruby-sdoc, add ruby-yard.
[native-inputs]: Remove bundler.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8acd05075c..60682bcbd7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2285,13 +2285,13 @@ documentation for Ruby code.")
 (define-public ruby-gem-hadar
   (package
     (name "ruby-gem-hadar")
-    (version "1.3.1")
+    (version "1.9.1")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "gem_hadar" version))
               (sha256
                (base32
-                "1j8qri4m9wf8nbfv0kakrgsv2x8vg10914xgm6f69nw8zi3i39ws"))))
+                "1zxvd9l95rbks7x3cxn396w0sn7nha5542bf97v8akkn4vm7nby9"))))
     (build-system ruby-build-system)
     ;; This gem needs itself at development time. We disable rebuilding of the
     ;; gemspec to avoid this loop.
@@ -2305,9 +2305,7 @@ documentation for Ruby code.")
     (propagated-inputs
      `(("git" ,git)
        ("ruby-tins" ,ruby-tins)
-       ("ruby-sdoc" ,ruby-sdoc)))
-    (native-inputs
-     `(("bundler" ,bundler)))
+       ("ruby-yard" ,ruby-yard)))
     (synopsis "Library for the development of Ruby gems")
     (description
      "This library contains some useful functionality to support the