summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-06 14:45:12 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-04-07 14:50:28 +0100
commit6482c3e358edda7c9add6b3bff05cc9ee68c8896 (patch)
tree2d28f0ed9ac95e7c8ce0fbb15d0a982c790241cf /gnu
parent5bd109b81122ed642bc66cb574d48cc9f45c0cab (diff)
downloadguix-6482c3e358edda7c9add6b3bff05cc9ee68c8896.tar.gz
gnu: Add perl-scalar-string.
* gnu/packages/perl.scm (perl-scalar-string): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c04d4ab389..6e71f71a4f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8013,6 +8013,37 @@ and @code{deserialize_regexp}.")
 safely on things that may not be objects.")
     (license (package-license perl))))
 
+(define-public perl-scalar-string
+  (package
+    (name "perl-scalar-string")
+    (version "0.003")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append
+            "mirror://cpan/authors/id/Z/ZE/ZEFRAM/Scalar-String-"
+            version ".tar.gz"))
+      (sha256
+       (base32
+        "0llbsqk7rsg9p7l1f4yk6iv7wij91gvavprsqhnb04w7nz4ifjpm"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)
+       ("perl-test-pod" ,perl-test-pod)
+       ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+    (home-page "https://metacpan.org/release/Scalar-String")
+    (synopsis "String aspects of scalars")
+    (description "@code{Scalar::String} is about the string part of
+plain Perl scalars.  A scalar has a string value, which is notionally
+a sequence of Unicode codepoints but may be internally encoded in
+either ISO-8859-1 or UTF-8.  In places, more so in older versions of
+Perl, the internal encoding shows through.  To fully understand Perl
+strings it is necessary to understand these implementation details.
+This module provides functions to classify a string by encoding and to
+encode a string in a desired way.  The module is implemented in XS,
+with a pure Perl backup version for systems that cannot handle XS.")
+    (license perl-license)))
+
 (define-public perl-scope-guard
   (package
     (name "perl-scope-guard")