summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-08-24 23:09:10 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-26 09:24:56 +0200
commit7e662338116f1257e6234e3e70c38906ae24c268 (patch)
tree03ea262025326373592e6c524b5faa027edb4bab /gnu
parentd6a454addfc54104bca9ec4f4a56251bf4a0ad46 (diff)
downloadguix-7e662338116f1257e6234e3e70c38906ae24c268.tar.gz
gnu: drawpile: Build with libmicrohttpd 0.9.71.
* gnu/packages/graphics.scm (drawpile): Update to 2.1.17-1.ed1a75deb.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm76
1 files changed, 40 insertions, 36 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 553d23f014..35b96351ba 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1654,41 +1654,45 @@ Automated palette selection is supported.")
     (license license:expat)))
 
 (define-public drawpile
-  (package
-    (name "drawpile")
-    (version "2.1.17")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/drawpile/Drawpile")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "08w8vad8pw4a8kkshys1kd2kjvzpj62klxxxp904rx0qazw5hl80"))))
-    (build-system qt-build-system)
-    (arguments
-     '(#:configure-flags (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
-    (native-inputs
-     `(("extra-cmake-modules" ,extra-cmake-modules)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("giflib" ,giflib)
-       ("karchive" ,karchive)
-       ("kdnssd" ,kdnssd)
-       ("libmicrohttpd" ,libmicrohttpd)
-       ("libsodium" ,libsodium)
-       ("libvpx" ,libvpx)
-       ("libxi" ,libxi)
-       ;; ("miniupnpc" ,miniupnpc) ;segfaults for some reason
-       ("qtbase" ,qtbase)
-       ("qtkeychain" ,qtkeychain)
-       ("qtmultimedia" ,qtmultimedia)
-       ("qtsvg" ,qtsvg)
-       ("qtx11extras" ,qtx11extras)))
-    (home-page "https://drawpile.net")
-    (synopsis "Collaborative drawing program")
-    (description "Drawpile is a drawing program that allows share the canvas
+  ;; This commit fix building with libmicrohttpd>=0.71.
+  (let ((commit "ed1a75deb113da2d1df91a28f557509c4897130e")
+        (revision "1"))
+    (package
+      (name "drawpile")
+      (version (string-append "2.1.17-" revision "." (string-take commit 9)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/drawpile/Drawpile")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1y21h1hk9ipkjvhjgas0c5hkjyan92vsxbxrn60c906hzqln2fr1"))))
+      (build-system qt-build-system)
+      (arguments
+       '(#:configure-flags
+         (list "-DTESTS=ON" "-DTOOLS=ON" "-DKIS_TABLET=ON")))
+      (native-inputs
+       `(("extra-cmake-modules" ,extra-cmake-modules)
+         ("pkg-config" ,pkg-config)))
+      (inputs
+       `(("giflib" ,giflib)
+         ("karchive" ,karchive)
+         ("kdnssd" ,kdnssd)
+         ("libmicrohttpd" ,libmicrohttpd)
+         ("libsodium" ,libsodium)
+         ("libvpx" ,libvpx)
+         ("libxi" ,libxi)
+         ;; ("miniupnpc" ,miniupnpc) ;segfaults for some reason
+         ("qtbase" ,qtbase)
+         ("qtkeychain" ,qtkeychain)
+         ("qtmultimedia" ,qtmultimedia)
+         ("qtsvg" ,qtsvg)
+         ("qtx11extras" ,qtx11extras)))
+      (home-page "https://drawpile.net")
+      (synopsis "Collaborative drawing program")
+      (description "Drawpile is a drawing program that allows share the canvas
 with other users in real time.
 
 Some feature highlights:
@@ -1704,4 +1708,4 @@ Some feature highlights:
 @item Encrypted connections using SSL
 @item Automatic port forwarding with UPnP
 @end itemize\n")
-    (license license:gpl3+)))
+      (license license:gpl3+))))