summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-09-11 17:27:56 +0100
committerLudovic Courtès <ludo@gnu.org>2020-09-13 23:34:22 +0200
commitae286b58c85395e9a3cea813eff00d4ca3cdffae (patch)
tree04b6418087b55cc0682a35ea5d8b785c2dd6c4f9 /gnu
parentfce852c45817793998dc4b7f174033b4796b1b88 (diff)
downloadguix-ae286b58c85395e9a3cea813eff00d4ca3cdffae.tar.gz
gnu: Add meson 0.55.1.
* gnu/packages/build-tools.scm (meson-0.55): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/build-tools.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 7213c1bd0b..32e8f4cc82 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -211,6 +211,21 @@ files}, are written in a custom domain-specific language (@dfn{DSL}) that
 resembles Python.")
     (license license:asl2.0)))
 
+;; Added temporarily for packages that need it.
+;; TODO: Remove when core-updates is merged.
+(define-public meson-0.55
+  (package
+    (inherit meson)
+    (version "0.55.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/mesonbuild/meson/"
+                                  "releases/download/" version  "/meson-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1070kjiirxxdfppmrhi3wsc6rykay1zlciqrzayjhjg0hkw42mrv"))))))
+
 (define-public meson-for-build
   (package
     (inherit meson)