summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2018-11-11 12:26:44 +0100
committerClément Lassieur <clement@lassieur.org>2018-11-11 15:58:50 +0100
commit4ad3786b7b61073005f024f33465e6b7a4a952ad (patch)
treef793522783e9d4505e11e2f28f55040a0bac6dab /gnu
parent902068b43664b862dfcbb9172f41778d576e3ae0 (diff)
downloadguix-4ad3786b7b61073005f024f33465e6b7a4a952ad.tar.gz
gnu: Add python-precis-i18n.
* gnu/packages/messaging.scm (python-precis-i18n): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5f81c428ff..b6b0ad75a4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14611,3 +14611,22 @@ on regular expressions.")
              (propagated-inputs
               `(("python2-enum34" ,python2-enum34)
                 ,@(package-propagated-inputs reparser))))))
+
+(define-public python-precis-i18n
+  (package
+    (name "python-precis-i18n")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "precis_i18n" version))
+       (sha256
+        (base32
+         "0gjhvwd8aifx94rl1ag08vlmndyx2q3fkyqb0c4i46x3p2bc2yi2"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/byllyfish/precis_i18n")
+    (synopsis "Implementation of the PRECIS framework")
+    (description
+     "This module implements the PRECIS Framework as described in RFC 8264,
+RFC 8265 and RFC 8266.")
+    (license license:expat)))