summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-06-28 08:33:25 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-16 12:22:00 -0400
commit68c3ca933d1621586b9e73944b194e5304130198 (patch)
tree40176dac92ecb619199a9a904fef4fec3d72690b /gnu
parent5229bea128bc225583198d76678d758eafb83023 (diff)
downloadguix-68c3ca933d1621586b9e73944b194e5304130198.tar.gz
gnu: evolution-data-server: Update to 3.30.5.
* gnu/packages/gnome.scm (evolution-data-server): Update to 3.30.5.
[arguments]: Remove "-std=gnu++11" configure flag. Disable more failing tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3b5deb2a82..b0bbc12cdf 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5155,7 +5155,7 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
 (define-public evolution-data-server
   (package
     (name "evolution-data-server")
-    (version "3.30.2")
+    (version "3.30.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -5163,7 +5163,7 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0h4f71kpf2ypdgifg369z35pk4cq99daw540yzjpax52grav2fjv"))))
+                "1s952wyhgcbmq9nfgk75v15zdy1h3wy5p5rmkqibaavmc0pk3mli"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
@@ -5177,13 +5177,11 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
                "-DENABLE_GOOGLE=OFF"          ;disable Google Contacts support
                "-DENABLE_GOOGLE_AUTH=OFF"     ;disable Google authentication
                "-DENABLE_VALA_BINDINGS=ON"
-               ;; FIXME: Building against ICU 60 requires C++11 or higher.  Remove
-               ;; "-std=gnu++11" when our default compiler is >= GCC6.
                ;; FIXME: Temporarily use "-DU_USING_ICU_NAMESPACE=1" until
                ;; evolution-data-server has been updated to qualify ICU types
                ;; explicitly, as required by ICU 61 and later.  See:
                ;; <https://ssl.icu-project.org/repos/icu/trunk/icu4c/readme.html#RecBuild>
-               "-DCMAKE_CXX_FLAGS=-std=gnu++11 -DU_USING_ICU_NAMESPACE=1"
+               "-DU_USING_ICU_NAMESPACE=1"
                (string-append "-DCMAKE_INSTALL_RPATH=" lib ";"
                               (string-append lib "/evolution-data-server;")
                               (string-join runpaths ";"))