summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-29 22:08:20 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-08-29 22:12:24 -0400
commit20c05ea94af8f55821ffe203d9f0d97ab0e0748f (patch)
tree73f656c8555629509279cc2ac9e7adace3084f41 /gnu
parent532164194a96bb3a0e957bf2fe5e7487cf53488d (diff)
downloadguix-20c05ea94af8f55821ffe203d9f0d97ab0e0748f.tar.gz
gnu: Make ruby-diff-lcs a public package.
* gnu/packages/ruby.scm (ruby-diff-lcs-for-rspec): Rename this...
  (ruby-diff-lcs): ... to this, and export it.
  (ruby-rspec-expectation, ruby-rspec-mocks): Use new varaible.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0e45e06305..561fe4d986 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -254,7 +254,7 @@ groups.")
     (home-page "https://github.com/rspec/rspec-core")
     (license license:expat)))
 
-(define ruby-diff-lcs-for-rspec
+(define-public ruby-diff-lcs
   (package
     (name "ruby-diff-lcs")
     (version "1.2.5")
@@ -290,7 +290,7 @@ standard diff-like tool.")
      '(#:tests? #f)) ; avoid dependency cycles
     (propagated-inputs
      `(("ruby-rspec-support" ,ruby-rspec-support)
-       ("ruby-diff-lcs" ,ruby-diff-lcs-for-rspec)))
+       ("ruby-diff-lcs" ,ruby-diff-lcs)))
     (synopsis "RSpec expectations library")
     (description "Rspec-expectations provides a simple API to express expected
 outcomes of a code example.")
@@ -312,7 +312,7 @@ outcomes of a code example.")
      '(#:tests? #f)) ; avoid dependency cycles
     (propagated-inputs
      `(("ruby-rspec-support" ,ruby-rspec-support)
-       ("ruby-diff-lcs" ,ruby-diff-lcs-for-rspec)))
+       ("ruby-diff-lcs" ,ruby-diff-lcs)))
     (synopsis "RSpec stubbing and mocking library")
     (description "Rspec-mocks provides RSpec's \"test double\" framework, with
 support for stubbing and mocking.")