summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2016-04-20 10:17:28 +0200
committerAndy Wingo <wingo@igalia.com>2016-05-04 17:00:02 +0200
commit11057c4b58d766f358bc439690b9765bee735772 (patch)
tree33c47fe47c70137cb92e9ac770742e16ec0d3fb6 /gnu
parentac47ad99a4045262e235b7ae0b6f868944aad071 (diff)
downloadguix-11057c4b58d766f358bc439690b9765bee735772.tar.gz
gnu: bitlbee: Incorporate upstream pre-release patches.
* gnu/packages/messaging.scm (%bitlbee-buddy-nick-change-patch):
(%bitlbee-always-use-nicks-patch): New variables.
(bitlbee): Add new patches.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f094f8537d..a79efc3366 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -91,6 +91,24 @@ keys, no previous conversation is compromised.")
     (home-page "https://otr.cypherpunks.ca/")
     (license (list lgpl2.1 gpl2))))
 
+;; These patches together fix https://github.com/bitlbee/bitlbee/pull/55, are
+;; already upstream, and should be unnecessary when the next bitlbee comes
+;; out.
+(define %bitlbee-buddy-nick-change-patch
+  (origin
+    (method url-fetch)
+    (uri "https://github.com/bitlbee/bitlbee/commit/a42fda42.patch")
+    (sha256
+     (base32
+      "1mzjhcdn0rxir5mzgqz9kv142ai38p1iq2lajqx89wb7x0bp51zx"))))
+(define %bitlbee-always-use-nicks-patch
+  (origin
+    (method url-fetch)
+    (uri "https://github.com/bitlbee/bitlbee/commit/3320d6d9.patch")
+    (sha256
+     (base32
+      "14d9kb5zdzh5hzakdvrbviz83rix0j2lq9rzb58b2fn92fp8yixd"))))
+
 (define-public bitlbee
   (package
     (name "bitlbee")
@@ -100,7 +118,10 @@ keys, no previous conversation is compromised.")
               (uri (string-append "https://get.bitlbee.org/src/bitlbee-"
                                   version ".tar.gz"))
               (sha256
-               (base32 "0mza8lnfwibmklz8hdzg4f7p83hblf4h6fbf7d732kzpvra5bj39"))))
+               (base32 "0mza8lnfwibmklz8hdzg4f7p83hblf4h6fbf7d732kzpvra5bj39"))
+              (patches
+               (list %bitlbee-buddy-nick-change-patch
+                     %bitlbee-always-use-nicks-patch))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("check" ,check)))