summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-03-15 23:14:42 -0400
committerKei Kebreau <kei@openmailbox.org>2017-03-15 23:14:42 -0400
commit26a657f06a24e62181fcfe1e25f4ab5bd21075b4 (patch)
treed24b4d3528b31954a105dbc9bdd7becd45180a69 /gnu
parent5b5cf3c7659ee33bb981135708929c8f0a46aec8 (diff)
downloadguix-26a657f06a24e62181fcfe1e25f4ab5bd21075b4.tar.gz
gnu: Add prboom-plus.
* gnu/packages/games.scm (prboom-plus): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm47
1 files changed, 46 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 936cfaa9a6..f264ef206f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -19,7 +19,7 @@
 ;;; Copyright © 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
-;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -73,6 +73,7 @@
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages haskell)
   #:use-module (gnu packages mp3)
+  #:use-module (gnu packages music)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
   #:use-module (gnu packages ncurses)
@@ -195,6 +196,50 @@ scriptable with Guile.")
 Chess).  It is similar to standard chess but this variant is far more complicated.")
     (license license:gpl3+)))
 
+(define-public prboom-plus
+  (package
+   (name "prboom-plus")
+   (version "2.5.1.4")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://sourceforge/" name "/" name "/"
+                                version "/" name "-" version ".tar.gz"))
+            (sha256
+             (base32
+              "151v6nign86m1a2vqz27krsccpc9m4d1jax4y43v2fa82wfj9qp0"))
+            (modules '((guix build utils)))
+            (snippet
+             '(substitute* "src/version.c"
+                           (("__DATE__") "")
+                           (("__TIME__") "")))))
+   (build-system gnu-build-system)
+   (arguments
+    '(#:configure-flags '("--disable-cpu-opt")
+      #:make-flags `(,(string-append "gamesdir="
+                                     (assoc-ref %outputs "out") "/bin"))
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'set-paths 'set-sdl'paths
+          (lambda* (#:key inputs #:allow-other-keys)
+            (setenv "CPATH"
+                    (string-append (assoc-ref inputs "sdl-union")
+                                   "/include/SDL"))
+            #t)))))
+   (inputs
+    `(("fluidsynth" ,fluidsynth)
+      ("glu" ,glu)
+      ("libmad" ,libmad)
+      ("libpng" ,libpng)
+      ("libvorbis" ,libvorbis)
+      ("pcre" ,pcre)
+      ("portmidi" ,portmidi)
+      ("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net)))))
+   (home-page "http://prboom-plus.sourceforge.net/")
+   (synopsis "Version of the classic 3D shoot'em'up game Doom")
+   (description
+    "PrBoom+ is a Doom source port developed from the original PrBoom project.")
+   (license license:gpl2+)))
+
 (define-public xshogi
   (package
     (name "xshogi")