summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2017-03-15 18:14:43 -0400
committerLeo Famulari <leo@famulari.name>2017-03-15 18:24:30 -0400
commit5b5cf3c7659ee33bb981135708929c8f0a46aec8 (patch)
treecd6569307a46579361c132ee607e45450410f0b6 /gnu
parent80a725726d3b3a62c69c9f80d35a898dcea8ad90 (diff)
downloadguix-5b5cf3c7659ee33bb981135708929c8f0a46aec8.tar.gz
gnu: Add tftp-hpa.
* gnu/packages/networking.scm (tftp-hpa): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 95253687cd..e36903b8af 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1141,3 +1141,28 @@ IPFIX, RSPAN, CLI, LACP, 802.1ag).")
      "Command line interface for testing internet bandwidth using
 speedtest.net.")
     (license license:asl2.0)))
+
+(define-public tftp-hpa
+  (package
+    (name "tftp-hpa")
+    (version "5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kernel.org/software/"
+                                  "network/tftp/tftp-hpa/tftp-hpa-" version
+                                  ".tar.xz"))
+              (sha256
+               (base32
+                "12vidchglhyc20znq5wdsbhi9mqg90jnl7qr9qs8hbvaz4fkdvmg"))))
+    (build-system gnu-build-system)
+    (arguments `(#:tests? #f)) ; no test target
+    (synopsis "HPA's tftp client")
+    (description
+     "This is a tftp client derived from OpenBSD tftp with some extra options
+added and bugs fixed.  The source includes readline support but it is not
+enabled due to license conflicts between the BSD advertising clause and the GPL.")
+    (home-page "http://git.kernel.org/cgit/network/tftp/tftp-hpa.git/about/")
+    ;; Some source files are distributed under a 3-clause BSD license, and
+    ;; others under a 4-clause BSD license. Refer to the files in the source
+    ;; distribution for clarification.
+    (license (list license:bsd-3 license:bsd-4))))