summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-03 15:03:36 +0100
committerLeo Famulari <leo@famulari.name>2017-02-06 13:46:45 +0100
commit686d425904f53af1c6e0f1fa7282fd00343a5725 (patch)
tree6ad07b1bad5fefb598cb3ad83d603b0e50dc09a4 /gnu
parent6edc15798df14145c154b91c29847eb5a77f6b43 (diff)
downloadguix-686d425904f53af1c6e0f1fa7282fd00343a5725.tar.gz
gnu: certbot, python-acme: Update to 0.11.1.
* gnu/packages/tls.scm (python-acme, python2-acme): Update to 0.11.1.
(certbot): Update to 0.11.1.
[version]: Use python-acme's version.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 5253381830..b28eb164b0 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -506,13 +506,14 @@ security, and applying best practice development processes.")
 (define-public python-acme
   (package
     (name "python-acme")
-    (version "0.10.2")
+    ;; Remember to update the hash of certbot when updating python-acme.
+    (version "0.11.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "acme" version))
       (sha256
        (base32
-        "0y6y8d66yvwdcby96g0dlqqwy72b81yh6hws4va8r7w4aribcrb4"))))
+        "0kk95iqxygrg0cd66kq8kbyalg2x5pz9hn1175cgwgf1vy72adfv"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -555,13 +556,15 @@ security, and applying best practice development processes.")
 (define-public certbot
   (package
     (name "certbot")
-    (version "0.10.2")
+    ;; Certbot and python-acme are developed in the same repository, and their
+    ;; versions should remain synchronized.
+    (version (package-version python-acme))
     (source (origin
               (method url-fetch)
               (uri (pypi-uri name version))
               (sha256
                (base32
-                "0c8nidbbq8p4rjhcrw31saw04n5rz4zgr08chbch17gw03hrqwik"))))
+                "1wis5kgqcsrs60kkcmbrbx8z9yasmwa6lg9ir5im232hdm4285vc"))))
     (build-system python-build-system)
     (arguments
      `(#:python ,python-2