summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-26 16:22:25 -0500
committerLeo Famulari <leo@famulari.name>2016-11-26 16:23:42 -0500
commite30abbbb02583021eaf7f0533f234ea92f291d55 (patch)
treeeefb0f00371d59b846ec4d3cbf52981cebf5509e /gnu
parenta282cdae107c8aec512b563f25dd411183ef2830 (diff)
downloadguix-e30abbbb02583021eaf7f0533f234ea92f291d55.tar.gz
gnu: cyrus-sasl: Incorporate grafted patch.
* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[source]: Use
'cyrus-sasl-CVE-2013-4122.patch'.
[replacement]: Remove field.
(cyrus-sasl/fixed): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cyrus-sasl.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 89a4a49797..3c6a87828a 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -31,7 +31,6 @@
 (define-public cyrus-sasl
   (package
    (name "cyrus-sasl")
-   (replacement cyrus-sasl/fixed)
    (version "2.1.26")
    (source (origin
             (method url-fetch)
@@ -41,6 +40,7 @@
                        (string-append
                         "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
                         version ".tar.gz")))
+            (patches (search-patches "cyrus-sasl-CVE-2013-4122.patch"))
             (sha256 (base32
                      "1hvvbcsg21nlncbgs0cgn3iwlnb3vannzwsp6rwvnn9ba4v53g4g"))))
    (build-system gnu-build-system)
@@ -66,10 +66,3 @@ server writers.")
    (license (license:non-copyleft "file://COPYING"
                                   "See COPYING in the distribution."))
    (home-page "http://cyrusimap.web.cmu.edu")))
-
-(define cyrus-sasl/fixed
-  (package
-    (inherit cyrus-sasl)
-    (source (origin
-              (inherit (package-source cyrus-sasl))
-              (patches (search-patches "cyrus-sasl-CVE-2013-4122.patch"))))))