summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-10-10 00:51:59 -0400
committerLeo Famulari <leo@famulari.name>2020-10-13 16:49:24 -0400
commit021e92780b8ce87efde70bb069cb6a8d762e544c (patch)
tree7b8fd48b21bbd607e9203e3a8df4d09f3274cf57 /gnu
parent1197b8b20f4fca4ce03bbc5fa75e18d54e3717c0 (diff)
downloadguix-021e92780b8ce87efde70bb069cb6a8d762e544c.tar.gz
gnu: Add SRT 1.4.1.
* gnu/packages/networking.scm (srt-1.4.1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f7093e1b35..5c57ef2b6d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -13,7 +13,7 @@
 ;;; Copyright © 2016 Benz Schenk <benz.schenk@uzh.ch>
 ;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2017, 2019 Gábor Boskovits <boskovits@gmail.com>
@@ -346,6 +346,24 @@ performance across unpredictable networks, such as the Internet.")
     (home-page "https://www.srtalliance.org/")
     (license license:mpl2.0)))
 
+;; FFmpeg, GStreamer, and VLC don't support SRT 1.4.2 yet.
+(define-public srt-1.4.1
+  (package
+    (inherit srt)
+    (name "srt")
+    (version "1.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/Haivision/srt.git")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "01xaq44j95kbgqfl41pnybvqy0yq6wd4wdw88ckylzf0nzp977xz"))))))
+
 (define-public lksctp-tools
   (package
     (name "lksctp-tools")