summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-15 20:47:07 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-15 20:47:07 +0100
commit0565587c54bf61f75012fcccb599a592f1e32440 (patch)
tree1ede7e0fd438d5b8ccb7dd9030152a8d5ee2ec94 /gnu
parentb702b52de35cb328b72237756517338919da52a9 (diff)
downloadguix-0565587c54bf61f75012fcccb599a592f1e32440.tar.gz
gnu: xboard: Update to 4.8.0.
* gnu/packages/games.scm (xboard): Update to 4.8.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a9c4d6bd11..9b8983e848 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -398,7 +399,7 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
 (define-public xboard
   (package
     (name "xboard")
-    (version "4.7.3")
+    (version "4.8.0")
     (source
      (origin
        (method url-fetch)
@@ -406,17 +407,8 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
                            ".tar.gz"))
        (sha256
         (base32
-         "1amy9krr0qkvcc7gnp3i9x9ma91fc5cq8hy3gdc7rmfsaczv1l3z"))))
+         "05rdj0nyirc4g1qi5hhrjy45y52ihp1j3ldq2c5bwrz0gzy4i3y8"))))
     (build-system gnu-build-system)
-    (arguments
-     '(#:phases
-       (alist-cons-before 
-        'configure 'pre-conf
-        ;; This is GNU.  So use gnuchess as the first choice of engine
-        (lambda _
-          (substitute* "xboard.conf.in" 
-            (("-firstChessProgram fairymax") "-firstChessProgram gnuchess")))
-        %standard-phases)))
     (inputs `(("cairo" ,cairo)
               ("librsvg" ,librsvg)
               ("libxt" ,libxt)