summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMiguel Ángel Arruga Vivas <rosen644835@gmail.com>2019-11-08 02:13:38 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-10 23:50:36 +0100
commit172e121d01f676d532a9a1f9e977f4ddb9b3dc01 (patch)
treeb5216c4e8cac2e24c4c3b46816664d9917a1a130 /gnu
parent72332f3c8a9fcdb914b3ae75b748c6726174f9ec (diff)
downloadguix-172e121d01f676d532a9a1f9e977f4ddb9b3dc01.tar.gz
gnu: qemu: Add upstream patch for failing test.
Fixes <https://bugs.gnu.org/37860>.
Reported by Danny Milosavljevic <dannym@scratchpost.org>.

* gnu/packages/virtualization.scm (qemu)[patches]: Add upstream patch
to fix tests on linux-libre >= 5.3.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/virtualization.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index f113eee5f7..ca27c14a47 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -114,7 +114,16 @@
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1ih9v6gxgild3m4g80ld4dr3wp9db3bpy203k73fxgc9hqhn0vk5"))))
+               "1ih9v6gxgild3m4g80ld4dr3wp9db3bpy203k73fxgc9hqhn0vk5"))
+             (patches
+              (list
+               ;; Fix an ordering issue with recent kernels, see
+               ;; <https://bugs.gnu.org/37860>.
+               (qemu-patch
+                "bf9e0313c27d8e6ecd7f7de3d63e1cb25d8f6311"
+                "qemu-tests-make-filemonitor-test-more-robust.patch"
+                (base32
+                 "1242wqpr8id3cn88pzbig3sqh4znml0g0h2mwdmdyhp81blq7s7n"))))))
     (build-system gnu-build-system)
     (arguments
      '(;; Running tests in parallel can occasionally lead to failures, like: