summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 12:58:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:46 +0200
commit19e31f91d076164cb6896ebd3d4a918f4d7afec0 (patch)
treedc8ef38ecad78b7744f5f388750a01ae3ab8c3ce /gnu
parent483d8af60c423b9b241db33146c764377dcbfdef (diff)
downloadguix-19e31f91d076164cb6896ebd3d4a918f4d7afec0.tar.gz
gnu: Add texlive-hyphen-sanskrit.
* gnu/packages/tex.scm (texlive-hyphen-sanskrit): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 93599ad089..76458ebe53 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2116,6 +2116,22 @@ Lia Rumantscha (Romansh language society).")
 T2A and UTF-8 encodings.")
     (license license:lppl1.2+)))
 
+(define-public texlive-hyphen-sanskrit
+  (package
+    (inherit (texlive-hyphen-package
+              "texlive-hyphen-sanskrit" "sa"
+              (list "/doc/generic/hyph-utf8/sa/hyphenmin.txt"
+                    "/tex/generic/hyph-utf8/patterns/tex/hyph-sa.tex")
+              (base32
+               "0grnn09l4i5yridx10yhm6dg9sbhgc2pmsp1p6hrcy7lzkqwdvs3")))
+    (synopsis "Sanskrit hyphenation patterns")
+    (description "This package provides hyphenation patterns for Sanskrit and
+Prakrit in longdesc transliteration, and in Devanagari, Bengali, Kannada,
+Malayalam longdesc and Telugu scripts for Unicode engines.")
+    ;; "You may freely use, copy, modify and/or distribute this file."
+    (license (license:non-copyleft
+              "file:///tex/generic/hyph-utf8/patterns/tex/hyph-sa.tex"))))
+
 (define-public texlive-hyph-utf8
   (package
     (inherit (simple-texlive-package