summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-24 16:41:59 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-25 15:21:47 +0100
commit1c207a7658a237cf13585aa25f16042328ca767b (patch)
tree443635b61c761e42f8c8289428acb04b9bcd7721 /gnu
parentb9c7ed71b1c4110c3c8580f1bb8050c31324fa6a (diff)
downloadguix-1c207a7658a237cf13585aa25f16042328ca767b.tar.gz
gnu: Add Ragel.
* gnu/packages/ragel.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ragel.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/ragel.scm b/gnu/packages/ragel.scm
new file mode 100644
index 0000000000..6201482c9f
--- /dev/null
+++ b/gnu/packages/ragel.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ragel)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages))
+
+(define-public ragel
+  (package
+    (name "ragel")
+    (version "6.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.colm.net/files/ragel/ragel-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "02k6rwh8cr95f1p5sjjr3wa6dilg06572xz1v71dk8awmc7vw1vf"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.colm.net/open-source/ragel/")
+    (synopsis "State machine compiler")
+    (description
+     "Ragel compiles executable finite state machines from regular languages.
+Ragel targets C, C++, Obj-C, C#, D, Java, Go and Ruby.  Ragel state machines
+can not only recognize byte sequences as regular expression machines do, but
+can also execute code at arbitrary points in the recognition of a regular
+language.  Code embedding is done using inline operators that do not disrupt
+the regular language syntax.")
+    ;; GPLv2 (or later) with exception for generated code.
+    (license license:gpl2+)))
+