summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-05 22:40:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-11 23:45:08 +0100
commit2cc7ce317bfcd01a7b9f66b5c7be6172d7ae1bda (patch)
treed24990fa4eb266c4da7cbc954e7aa507172bc526 /gnu
parentdb46f2fcf4dd515b86c8a3259f4527f1c0280d5c (diff)
downloadguix-2cc7ce317bfcd01a7b9f66b5c7be6172d7ae1bda.tar.gz
gnu: Add LADSPA.
* gnu/packages/audio.scm (ladspa): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e157a9c176..9b8aeabed3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -137,6 +137,43 @@ synchronous execution of all clients, and low latency operation.")
     ;; Most files are under GPLv2+, but some headers are under LGPLv2.1+
     (license (list license:gpl2+ license:lgpl2.1+))))
 
+(define-public ladspa
+  (package
+    (name "ladspa")
+    (version "1.13")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://www.ladspa.org/download/ladspa_sdk_"
+                   version
+                   ".tgz"))
+             (sha256
+              (base32
+               "0srh5n2l63354bc0srcrv58rzjkn4gv8qjqzg8dnq3rs4m7kzvdm"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; the "test" target is a listening test only
+       #:phases
+       (alist-replace
+        'configure
+        (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+          (chdir "src")
+          (let ((out (assoc-ref outputs "out")))
+            (substitute* "makefile"
+              (("/usr/lib/ladspa/") (string-append out "/lib/ladspa/"))
+              (("/usr/include/")    (string-append out "/include/"))
+              (("/usr/bin/")        (string-append out "/bin/"))
+              (("-mkdirhier")       "mkdir -p")
+              (("^CC.*")            "CC = gcc\n")
+              (("^CPP.*")           "CPP = g++\n"))))
+        (alist-delete 'build %standard-phases))))
+    (home-page "http://ladspa.org")
+    (synopsis "Linux Audio Developer's Simple Plugin API (LADSPA)")
+    (description
+     "LADSPA is a standard that allows software audio processors and effects
+to be plugged into a wide range of audio synthesis and recording packages.")
+    (license license:lgpl2.1+)))
+
 (define-public liblo
   (package
     (name "liblo")