summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-07-17 21:35:05 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-18 15:36:58 +0200
commit330a6ff4ebf32625c34a5e337878482f02abfd96 (patch)
treed1ab4e4fefd243da6bef5771b5b304399de456db /gnu
parent0574bc8aa5932b36f171c374c34ab367f1837a32 (diff)
downloadguix-330a6ff4ebf32625c34a5e337878482f02abfd96.tar.gz
gnu: Add emacs-ccls.
* gnu/packages/emacs-xyz.scm (emacs-ccls): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8b9d3263b7..110a053b29 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13793,6 +13793,34 @@ text in neighboring sections.")
 Pandoc, the document-conversion tool.")
     (license license:bsd-3)))
 
+(define-public emacs-ccls
+  (let ((commit "2764ddd57b03646f0327ea680a954b4a67450aef")
+        (version "0.1")
+        (revision "1"))
+    (package
+      (name "emacs-ccls")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/MaskRay/emacs-ccls")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "16427jvzhjy8kpvlgl3qzkzppv98124hkgi8q8pv1h7m46k9lhh3"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-dash" ,emacs-dash)
+         ("emacs-projectile" ,emacs-projectile)
+         ("emacs-lsp-mode" ,emacs-lsp-mode)))
+      (home-page "https://github.com/MaskRay/emacs-ccls")
+      (synopsis "Emacs support for the @code{ccls} language server")
+      (description "This package extends @code{lsp-mode} to work with @code{C}
+and @code{C++} files through the @code{ccls} language server.")
+      (license license:bsd-3))))
+
 (define-public emacs-org-brain
   (package
     (name "emacs-org-brain")