summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 09:20:07 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:52:56 +0100
commit4bc1707dba0098d416cbe4b53a3077025a2cc422 (patch)
tree2367ad5ae6053e4cdc694d3e1873dee027f2faa9 /gnu
parentae807fdb3736f8fbe60caa2ac1fbf2511aab561e (diff)
downloadguix-4bc1707dba0098d416cbe4b53a3077025a2cc422.tar.gz
gnu: Add r-mgsub.
* gnu/packages/cran.scm (r-mgsub): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c41d6d953d..af5055c392 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27379,3 +27379,27 @@ context of discourse analysis.  Tools include removal/extraction/replacement of
 abbreviations, dates, dollar amounts, email addresses, hash tags, numbers,
 percentages, citations, person tags, phone numbers, times, and zip codes.")
     (license license:gpl2)))
+
+(define-public r-mgsub
+  (package
+    (name "r-mgsub")
+    (version "1.7.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "mgsub" version))
+        (sha256
+          (base32
+            "02l1b96zv36ia0c97wgcwfhi037mbn3wy9c64hcw0n0w67yj77rr"))))
+    (properties `((upstream-name . "mgsub")))
+    (build-system r-build-system)
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page
+      "https://cran.r-project.org/package=mgsub")
+    (synopsis
+      "Safe, Multiple, Simultaneous String Substitution")
+    (description
+      "Designed to enable simultaneous substitution in strings in a safe
+fashion.  Safe means it does not rely on placeholders (which can cause errors
+in same length matches).")
+    (license license:expat)))