summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-10 10:22:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-11 23:45:21 +0100
commit57238ff2b478ce3b08badc55f605282d87ef7765 (patch)
tree172d8bcf8bebb6bbe4731c8c739b6a170e84faca /gnu
parent2cc7ce317bfcd01a7b9f66b5c7be6172d7ae1bda (diff)
downloadguix-57238ff2b478ce3b08badc55f605282d87ef7765.tar.gz
gnu: Add rubberband.
* gnu/packages/audio.scm (rubberband): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9b8aeabed3..a1bf4382be 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -258,6 +258,34 @@ add functionality to support the needs of increasingly powerful audio
 software.")
     (license license:isc)))
 
+(define-public rubberband
+  (package
+    (name "rubberband")
+    (version "1.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "https://bitbucket.org/breakfastquay/rubberband/get/v"
+                              version
+                              ".tar.bz2"))
+              (sha256
+               (base32
+                "05amrbrxx0da3w7m237q51799r8xgs4ffqabi2qv06hq8dpcj386"))))
+    (build-system gnu-build-system)
+    (arguments `(#:tests? #f)) ; no check target
+    (inputs
+     `(("ladspa" ,ladspa)
+       ("libsamplerate" ,libsamplerate)
+       ("vamp" ,vamp)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://breakfastquay.com/rubberband/")
+    (synopsis "Audio time-stretching and pitch-shifting library")
+    (description
+     "Rubber Band is a library and utility program that permits changing the
+tempo and pitch of an audio recording independently of one another.")
+    (license license:gpl2+)))
+
 (define-public sratom
   (package
     (name "sratom")