summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 11:00:10 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:16 -0400
commit63904adcbc343e82a7b9b597d7b16d708406d76c (patch)
tree84a0e8ac2ed43cf5dd73cd305145e9b70049aa33 /gnu
parentc068727dbbd43dedbbec181cc23772becf10b5e6 (diff)
downloadguix-63904adcbc343e82a7b9b597d7b16d708406d76c.tar.gz
gnu: gdk-pixbuf: Disable failing tests.
* gnu/packages/gtk.scm (gdk-pixbuf) [arguments]<#:phases>['disable-failing-tests]: New phase.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 7b556c724c..145a0355e1 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -612,6 +612,12 @@ highlighting and other features typical of a source code editor.")
                   (string-append (assoc-ref inputs "docbook-xml")
                                  "/xml/dtd/docbook/"))))
              #t))
+         (add-before 'configure 'disable-failing-tests
+           (lambda _
+             (substitute* "tests/meson.build"
+               (("\\[ 'pixbuf-fail', \\['conform', 'slow'\\], \\],")
+                ""))
+             #t))
          ;; The slow tests take longer than the specified timeout.
          ,@(if (any (cute string=? <> (%current-system))
                     '("armhf-linux" "aarch64-linux"))