summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-10-10 00:52:24 -0400
committerLeo Famulari <leo@famulari.name>2020-10-13 16:49:27 -0400
commit64661754fd8a32b9298d24e815cdbe568a8ffe77 (patch)
tree8a82cb19946cc9b0ed2fa320a9269e93e08750c6 /gnu
parent021e92780b8ce87efde70bb069cb6a8d762e544c (diff)
downloadguix-64661754fd8a32b9298d24e815cdbe568a8ffe77.tar.gz
gnu: FFmpeg: Add support for Secure Reliable Transport (SRT).
* gnu/packages/video.scm (vlc)[inputs] Add srt-1.4.1.
[arguments]: Pass "--enable-libsrt" to #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7f0b203f74..8d80409401 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1455,6 +1455,8 @@ operate properly.")
        ("sdl" ,sdl2)
        ("soxr" ,soxr)
        ("speex" ,speex)
+       ;; FFmpeg is not yet compatible with SRT > 1.4.1.
+       ("srt" ,srt-1.4.1)
        ("twolame" ,twolame)
        ("vidstab" ,vidstab)
        ("x265" ,x265)
@@ -1539,6 +1541,7 @@ operate properly.")
                '())
          "--enable-libsoxr"
          "--enable-libspeex"
+         "--enable-libsrt"
          "--enable-libtheora"
          "--enable-libtwolame"
          "--enable-libvidstab"