summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-02-05 15:03:50 +0800
committer宋文武 <iyzsong@gmail.com>2015-02-05 15:29:41 +0800
commit666aa995f0486a0753a8bb68a5e32c675d0f8b5b (patch)
tree8898d6a298ce925d6f2e709bb3bff4cf1a38f0d0 /gnu
parentb907324d0551b266df625201a16fd5c4d1f53a38 (diff)
downloadguix-666aa995f0486a0753a8bb68a5e32c675d0f8b5b.tar.gz
gnu: sdl: Don't use dlopen for shared object loading.
* gnu/packages/sdl.scm (sdl)[arguments]<#:configure-flags>:
  Use '--disable-sdl-dlopen'.
  [propagated-inputs]: Add libcap.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sdl.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index f10120a631..ee18c1b5d0 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -58,16 +59,15 @@
              (patches (list (search-patch "sdl-libx11-1.6.patch")))))
     (build-system gnu-build-system)
     (arguments
-     '(;; Explicitly link against Xext because SDL tries to dlopen it and
-       ;; doesn't go very far otherwise (see
-       ;; <https://lists.gnu.org/archive/html/guix-devel/2013-11/msg00088.html>
-       ;; for details.)
-       #:configure-flags '("LDFLAGS=-lXext")
+     '(;; Explicitly link against shared libraries instead of dlopening them.
+       ;; For X11, ALSA, PulseAudio, etc.
+       #:configure-flags '("--disable-sdl-dlopen")
 
        #:tests? #f)) ; no check target
     (propagated-inputs
      ;; SDL headers include X11 headers.
-     `(("libx11" ,libx11)))
+     `(("libx11" ,libx11)
+       ("libcap" ,libcap))) ; 'libSDL.la' contain `-lcap'.
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("libxrandr" ,libxrandr)
               ("mesa" ,mesa)