summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-25 00:11:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-25 00:11:53 +0200
commit6ac6c1d28d8a89d0f9b0f15e7df2a011f24aa091 (patch)
tree5684dbeaab792e4b35f34310a56cce566725d880 /gnu
parent9962b877804b4fc347b60fae8445ddc5d3ad8bbe (diff)
downloadguix-6ac6c1d28d8a89d0f9b0f15e7df2a011f24aa091.tar.gz
gnu: python-geventhttpclient: Disable test that fails with Python 3.8.
* gnu/packages/python-web.scm (python-geventhttpclient)[arguments]: In the
check phase, add pytest flag to filter broken test.  While at it, don't
reorder the phase, as it now runs after install by default.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5423aa917e..a73128a77c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1978,14 +1978,16 @@ library.")
            (lambda _
              (delete-file "src/geventhttpclient/tests/test_client.py")
              #t))
-         (delete 'check)
-         (add-after 'install 'check
+         (replace 'check
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (add-installed-pythonpath inputs outputs)
              (invoke "py.test"  "src/geventhttpclient/tests" "-v"
                      ;; Append the test modules to sys.path to avoid
                      ;; namespace conflict which breaks SSL tests.
-                     "--import-mode=append")
+                     "--import-mode=append"
+                     ;; XXX: Disable test fails with Python 3.8:
+                     ;; https://github.com/gwik/geventhttpclient/issues/119
+                     "-k" (string-append "not test_cookielib_compatibility"))
              #t)))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))