summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-13 20:27:38 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-13 20:27:38 +0100
commit80393eeda23db166e2c3fde8fa884089b0e8dad4 (patch)
treee6a6c5c128420b9e6ba4460f36108e001d678409 /gnu
parentaa72d9afdfe2d65e73c426c280667323181ae592 (diff)
downloadguix-80393eeda23db166e2c3fde8fa884089b0e8dad4.tar.gz
gnu: procps: Remove the 'kill' and 'uptime' commands.
* gnu/packages/linux.scm (procps)[arguments]: Add #:modules.
  <install phase>: Remove kill* and uptime*.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 99adda92c9..fc95a0b896 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -446,7 +446,11 @@ providing the system administrator with some help in common tasks.")
     (build-system gnu-build-system)
     (inputs `(("ncurses" ,ncurses)))
     (arguments
-     '(#:phases (alist-replace
+     '(#:modules ((guix build utils)
+                  (guix build gnu-build-system)
+                  (srfi srfi-1)
+                  (srfi srfi-26))
+       #:phases (alist-replace
                  'configure
                  (lambda* (#:key outputs #:allow-other-keys)
                    ;; No `configure', just a single Makefile.
@@ -468,6 +472,13 @@ providing the system administrator with some help in common tasks.")
                             (system* "make" "install"
                                      (string-append "DESTDIR=" out)))
 
+                           ;; Remove commands and man pages redundant with
+                           ;; Coreutils.
+                           (let ((dup (append-map (cut find-files out <>)
+                                                  '("^kill" "^uptime"))))
+                             (for-each delete-file dup)
+                             #t)
+
                            ;; Sanity check.
                            (zero?
                             (system* (string-append out "/bin/ps")