summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-28 18:10:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-28 18:23:22 +0100
commit8473597f805a33f79a7977ccdc98addeea8bc0c9 (patch)
tree0eb3b9cec414196c73ec8c818ac2f1abffafa996 /gnu
parentfe3fb4e7ef253d990c4a734fb5460f8c5aaf5f46 (diff)
downloadguix-8473597f805a33f79a7977ccdc98addeea8bc0c9.tar.gz
gnu: Add r-ggvis.
* gnu/packages/cran.scm (r-ggvis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f68579da0d..202fba63a0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13442,3 +13442,32 @@ microarrays.")
      "This package provides tools for shrunken centroids regularized
 discriminant analysis for the purpose of classifying high dimensional data.")
     (license license:gpl2+)))
+
+(define-public r-ggvis
+  (package
+    (name "r-ggvis")
+    (version "0.4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggvis" version))
+       (sha256
+        (base32
+         "1bxggjr2313kfy895j0fvrv4bg7yh2z87907lk48i1kn5c9flchk"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-assertthat" ,r-assertthat)
+       ("r-dplyr" ,r-dplyr)
+       ("r-htmltools" ,r-htmltools)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-lazyeval" ,r-lazyeval)
+       ("r-magrittr" ,r-magrittr)
+       ("r-shiny" ,r-shiny)))
+    (home-page "https://ggvis.rstudio.com/")
+    (synopsis "Interactive grammar of graphics")
+    (description
+     "This package is a data visualization package for R providing an
+implementation of an interactive grammar of graphics, taking the best parts of
+ggplot2, combining them with the reactive framework of Shiny and drawing web
+graphics using Vega.")
+    (license license:gpl2)))