summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-12-05 00:38:58 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-12-05 00:38:58 +0100
commit89ca445c298980b7462e6bacff4c044e9e570729 (patch)
tree63ec3f673165a3fd77110216c8cd239e7cb0b576 /gnu
parentb96bd82133420383e58180d725af6c7e178cdc24 (diff)
downloadguix-89ca445c298980b7462e6bacff4c044e9e570729.tar.gz
gnu: sbcl-next: Update to 1.1.0.
* gnu/packages/web-browsers.scm (sbcl-next): Update to 1.1.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 7e1d612402..6caa486b84 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -442,6 +442,9 @@ features for productive professionals.")
                     ;; the illegal version will result in NIL in the .desktop
                     ;; file.
                     (lambda* (#:key outputs #:allow-other-keys)
+                      (with-output-to-file "version"
+                        (lambda _
+                          (format #t "~a" ,(package-version next-gtk-webkit))))
                       (invoke "make" "install-assets"
                               (string-append "PREFIX="
                                              (assoc-ref outputs "out"))))))))
@@ -453,14 +456,12 @@ features for productive professionals.")
        ("cl-strings" ,sbcl-cl-strings)
        ("cl-string-match" ,sbcl-cl-string-match)
        ("puri" ,sbcl-puri)
-       ("queues.simple-queue" ,sbcl-queues.simple-queue)
        ("sqlite" ,sbcl-cl-sqlite)
        ("parenscript" ,sbcl-parenscript)
        ("cl-json" ,sbcl-cl-json)
        ("swank" ,sbcl-slime-swank)
        ("cl-markup" ,sbcl-cl-markup)
        ("cl-css" ,sbcl-cl-css)
-       ("usocket" ,sbcl-usocket)
        ("bordeaux-threads" ,sbcl-bordeaux-threads)
        ("s-xml-rpc" ,sbcl-s-xml-rpc)
        ("unix-opts" ,sbcl-unix-opts)))