summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-02-18 21:30:53 -0500
committerMark H Weaver <mhw@netris.org>2015-02-05 14:05:37 -0500
commitaa7c7f21b39a63e1e9d25bf5ea7f94aa919bd872 (patch)
treed552b03cb77031f5662f81f7b8e0a265df619950 /gnu
parentea119a288f097b16ffa617daa1f07bae9aa6e65a (diff)
downloadguix-aa7c7f21b39a63e1e9d25bf5ea7f94aa919bd872.tar.gz
gnu: gnutls: Configure location of system-wide trust store.
* gnu/packages/gnutls.scm (gnutls): Configure the location of the system-wide
  trust store.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnutls.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/gnutls.scm b/gnu/packages/gnutls.scm
index ee75e84957..d3097a6751 100644
--- a/gnu/packages/gnutls.scm
+++ b/gnu/packages/gnutls.scm
@@ -81,7 +81,17 @@ specifications.")
      '(#:configure-flags
        (list (string-append "--with-guile-site-dir="
                             (assoc-ref %outputs "out")
-                            "/share/guile/site/2.0"))))
+                            "/share/guile/site/2.0")
+             ;; GnuTLS doesn't consult any environment variables to specify
+             ;; the location of the system-wide trust store.  Instead it has a
+             ;; configure-time option.  Unless specified, its configure script
+             ;; attempts to auto-detect the location by looking for common
+             ;; places in the filesystem, none of which are present in our
+             ;; chroot build environment.  If not found, then no default trust
+             ;; store is used, so each program has to provide its own
+             ;; fallback, and users have to configure each program
+             ;; independently.  This seems suboptimal.
+             "--with-default-trust-store-dir=/etc/ssl/certs")))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs