summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-25 15:48:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-25 15:50:22 +0300
commitb455439bcd6c3adb2b07e0ef6d385986e901f57f (patch)
treefe42701e22cf658486ae713150307c3e5e9b284d /gnu
parentfc899d4f73a9af38af5c1b11ddd150e4c21341a0 (diff)
downloadguix-b455439bcd6c3adb2b07e0ef6d385986e901f57f.tar.gz
gnu: python-tornado: Rearrange inputs.
* gnu/packages/python.scm (python-tornado)[properties]: Define
python2-variant.
[inputs]: Remove python-certifi, move python-backports-abc here from
native-inputs.
[native-inputs]: Remove python-setuptools.
(python2-tornado): Build with 'strip-python2-variant'.
[native-inputs]: Add python2-setuptools.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a798934eca..418ba7fc28 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4910,11 +4910,10 @@ It is written entirely in Python.")
        (sha256
         (base32 "1gzgwayl6hmc9jfcl88bni4jcsk2jcca9dn1rvrfsvnijcjx7hn9"))))
     (build-system python-build-system)
-    (inputs
-     `(("python-certifi" ,python-certifi)))
     (native-inputs
-     `(("python-backports-abc" ,python-backports-abc)
-       ("python-setuptools" ,python-setuptools)))
+     `(("python-certifi" ,python-certifi)))
+    (inputs
+     `(("python-backports-abc" ,python-backports-abc)))
     (home-page "http://www.tornadoweb.org/")
     (synopsis "Python web framework and asynchronous networking library")
     (description
@@ -4923,16 +4922,20 @@ originally developed at FriendFeed.  By using non-blocking network I/O,
 Tornado can scale to tens of thousands of open connections, making it ideal
 for long polling, WebSockets, and other applications that require a long-lived
 connection to each user.")
-    (license asl2.0)))
+    (license asl2.0)
+    (properties `((python2-variant . ,(delay python2-tornado))))))
 
 (define-public python2-tornado
-  (let ((tornado (package-with-python2 python-tornado)))
+  (let ((tornado (package-with-python2 (strip-python2-variant python-tornado))))
     (package (inherit tornado)
       (inputs
        `(("python2-backport-ssl-match-hostname"
           ,python2-backport-ssl-match-hostname)
-         ("python2-singledispatch", python2-singledispatch)
-         ,@(package-inputs tornado))))))
+         ("python2-singledispatch" ,python2-singledispatch)
+          ,@(package-inputs tornado)))
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs tornado))))))
 
 ;; the python- version can be removed with python-3.5
 (define-public python-backports-abc