summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-18 20:34:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-18 20:34:17 +0300
commitb694fd4bb37522a6c511dd247d9173ccfe088168 (patch)
tree0b2df088eba8a891eca174b06b6e6bb2bb845b19 /gnu
parent4c224ae87c1fda9c342ce66fe6e1d89b93ce564c (diff)
downloadguix-b694fd4bb37522a6c511dd247d9173ccfe088168.tar.gz
gnu: julia-constructionbase: Update to 1.2.1.
* gnu/packages/julia-xyz.scm (julia-constructionbase): Update to 1.2.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm35
1 files changed, 17 insertions, 18 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c5f81ae459..e0d8e33e9d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -402,25 +402,24 @@ build tree Yggdrasil.")
     (license license:expat)))
 
 (define-public julia-constructionbase
-  (let ((commit "de77e2865b554f9b078fd8c35b593cce0554ae02"))
-    (package
-      (name "julia-constructionbase")
-      (version "1.1.0")                 ;tag not created upstream
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/JuliaObjects/ConstructionBase.jl")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1y79sfj0rds1skl9j16p9161hwa9khm0xc2m4hgjcbh5zzvyr57v"))))
-      (build-system julia-build-system)
-      (home-page "https://juliaobjects.github.io/ConstructionBase.jl/dev/")
-      (synopsis "Primitive functions for construction of objects")
-      (description "This very lightweight package provides primitive functions
+  (package
+    (name "julia-constructionbase")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaObjects/ConstructionBase.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1bmx5c5z9jxmyf2xjwwl5lhs9czmwq4isl0bkr78fak4j8brqr4n"))))
+    (build-system julia-build-system)
+    (home-page "https://juliaobjects.github.io/ConstructionBase.jl/dev/")
+    (synopsis "Primitive functions for construction of objects")
+    (description "This very lightweight package provides primitive functions
 for construction of objects.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public julia-datastructures
   (package