summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:13:07 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:17 +0300
commitb870ee10099c84a6ee4f1e69e68a385843e1a60f (patch)
tree4ea6fd922c65954e54ecdedc0ee90b12f60f052a /gnu
parentabe8ef7f09c632c7889e0cc1b9d39a430cb92951 (diff)
downloadguix-b870ee10099c84a6ee4f1e69e68a385843e1a60f.tar.gz
gnu: Add emacs-stumpwm-mode.
* gnu/packages/emacs.scm (emacs-stumpwm-mode): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 95a3d053dd..402468e8cd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9943,3 +9943,32 @@ keep Parens and Indentation inline with one another.")
       (description "This package provides a Helm interface for EWW buffers,
 bookmarks and history.")
       (license license:gpl3+))))
+
+(define-public emacs-stumpwm-mode
+  (let ((commit "8fbe071d2c6c040794060a354eb377218dc10b35")
+        (revision "1"))
+    (package
+      (name "emacs-stumpwm-mode")
+      (version (string-append "0.0.1-" revision "."
+                              (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/stumpwm/stumpwm-contrib.git")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "1dfwsvz1c8w6j4jp0kzaz78ml3f5dp0a5pvf090kwpbpg176r7iq"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'chdir-elisp
+             ;; Elisp directory is not in root of the source.
+             (lambda _
+               (chdir "util/swm-emacs"))))))
+      (home-page "https://github.com/stumpwm/stumpwm-contrib")
+      (synopsis "Emacs minor-mode for Stumpwm")
+      (description "Emacs minor-mode for Stumpwm")
+      (license license:gpl3+))))