summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-11 21:11:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-13 23:13:35 +0100
commitc1718190d5c4c72a7f68d6f855cd6d86f96f54fc (patch)
tree799454c81592596d762dbc3fa8a2763f55561cd3 /gnu
parent4ed206639bb59949466af8d8bee63e189f8eb08b (diff)
downloadguix-c1718190d5c4c72a7f68d6f855cd6d86f96f54fc.tar.gz
gnu: Add lvtk.
* gnu/packages/audio.scm (lvtk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 4f83db8d6a..92ed2ac34f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -336,6 +336,39 @@ add functionality to support the needs of increasingly powerful audio
 software.")
     (license license:isc)))
 
+(define-public lvtk
+  (package
+    (name "lvtk")
+    (version "1.2.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://github.com/lvtk/lvtk/archive/"
+                                 version
+                                 ".tar.gz"))
+             (sha256
+              (base32
+               "03nbj2cqcklqwh50zj2gwm07crh5iwqbpxbpzwbg5hvgl4k4rnjd"))))
+    (build-system waf-build-system)
+    (arguments
+     `(#:tests? #f  ; no check target
+       #:python ,python-2
+       #:configure-flags
+       (list (string-append "--boost-includes="
+                            (assoc-ref %build-inputs "boost")
+                            "/include"))))
+    (inputs
+     `(("boost" ,boost)
+       ("lv2" ,lv2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/lvtk/lvtk")
+    (synopsis "C++ libraries for LV2 plugins")
+    (description
+     "The LV2 Toolkit (LVTK) contains libraries that wrap the LV2 C API and
+extensions into easy to use C++ classes.  It is the successor of
+lv2-c++-tools.")
+    (license license:gpl3+)))
+
 (define-public rubberband
   (package
     (name "rubberband")