summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-07-15 20:45:41 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-07-17 12:50:39 +0530
commite13714b642f38f46705b2a9f860b42ea14618390 (patch)
tree924ae581612c846fcb8cf81d1d0bfb3fb337372e /gnu
parent214cbec2cfb818a32005dee3d5ccb30a5ec7d4f4 (diff)
downloadguix-e13714b642f38f46705b2a9f860b42ea14618390.tar.gz
gnu: Add gnaural.
* gnu/packages/audio.scm (gnaural): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6532cb9188..3c5b6307eb 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -21,6 +21,7 @@
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3721,3 +3722,32 @@ library.")
     (description "FAudio is an XAudio reimplementation that focuses solely on
 developing fully accurate DirectX Audio runtime libraries.")
     (license license:zlib)))
+
+(define-public gnaural
+  (package
+    (name "gnaural")
+    (version "20110606")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/gnaural/Gnaural/gnaural_"
+                           version ".tar.xz"))
+       (sha256
+        (base32
+         "1gq519c0imsh57zklyi0f8h64l3ai48lh672c834470z8c6kvbfi"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("gtk+" ,gtk+-2)
+       ("libsndfile" ,libsndfile)
+       ("portaudio" ,portaudio)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://gnaural.sourceforge.net/")
+    (synopsis "Binaural beat synthesizer")
+    (description "Gnaural is a programmable auditory binaural beat synthesizer
+intended to be used for brainwave entrainment.  Gnaural supports creation of
+binaural beat tracks of different frequencies and exporting of tracks into
+different audio formats.  Gnaural can also be linked over the internet with
+other Gnaural instances, allowing synchronous sessions between many users.")
+    (license license:gpl2+)))