summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-05-05 19:40:31 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-05-06 02:26:03 +0530
commit99c1554c9ba1fd22d7dfdeba221088a3849ee27b (patch)
tree83d3dd63c41928dc85d05db794e67cd5c5c551f9 /gnu
parentd7dcaf8a3171bdd0f7c4ce1e887af15d5ded4df8 (diff)
downloadguix-99c1554c9ba1fd22d7dfdeba221088a3849ee27b.tar.gz
gnu: Add linuxdcpp.
* gnu/packages/direct-connect.scm (linuxdcpp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/direct-connect.scm82
2 files changed, 83 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 558239f7a9..c93dca64c5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -107,6 +107,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/dejagnu.scm			\
   %D%/packages/dico.scm				\
   %D%/packages/dictionaries.scm			\
+  %D%/packages/direct-connect.scm		\
   %D%/packages/disk.scm				\
   %D%/packages/display-managers.scm		\
   %D%/packages/django.scm			\
diff --git a/gnu/packages/direct-connect.scm b/gnu/packages/direct-connect.scm
new file mode 100644
index 0000000000..6796bf3bc8
--- /dev/null
+++ b/gnu/packages/direct-connect.scm
@@ -0,0 +1,82 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages direct-connect)
+  #:use-module (guix build-system python)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (gnu packages boost)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages gettext)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages version-control))
+
+(define-public linuxdcpp
+  (package
+    (name "linuxdcpp")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://launchpad.net/linuxdcpp/1.1/1.1.0/+download/linuxdcpp-"
+             version ".tar.bz2"))
+       (sha256
+        (base32
+         "12i92hirmwryl1qy0n3jfrpziwzb82f61xca9jcjwyilx502f0b6"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2
+       #:tests? #f ; no tests
+       #:phases
+       ;; TODO: Add scons-build-system and use it here.
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'build
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (mkdir-p out)
+               (zero? (system* "scons" (string-append "PREFIX=" out)
+                               "-j" (number->string (parallel-job-count)))))))
+         (replace 'install
+           (lambda _
+             (zero? (system* "scons" "install")))))))
+    (inputs
+     `(("boost" ,boost)
+       ("bzip2" ,bzip2)
+       ("gtk+" ,gtk+-2)
+       ("libglade" ,libglade)
+       ("libnotify" ,libnotify)
+       ("openssl" ,openssl)))
+    (native-inputs
+     `(("bazaar" ,bazaar)
+       ("gettext-minimal" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)
+       ("scons" ,scons)))
+    (home-page "https://launchpad.net/linuxdcpp/")
+    (synopsis "Direct Connect client")
+    (description "LinuxDC++ is a Direct Connect (DC) client.  Direct Connect
+is a peer-to-peer file-sharing protocol.  Clients connect to a central hub
+where they can chat or share files with one another.  Users can view other
+users' list of shared files or search the hub for files.")
+    (license license:gpl2+)))