summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-04-19 11:02:43 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-05-12 10:49:49 -0400
commit7fd178a903d98e0e2c568b6bade2ea738bf6b73c (patch)
tree5b16f7a04fba5a6059029093fdc81f9a0d531cef /gnu
parent616b3e8f1b3c0c1fbf3226284e62ee04830afeb6 (diff)
downloadguix-7fd178a903d98e0e2c568b6bade2ea738bf6b73c.tar.gz
gnu: gnome-user-share: Update to 3.34.0.
* gnu/packages/gnome.scm (gnome-user-share): Update to 3.34.0.
[arguments]: Adjust configure flags accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d8dc94fa92..d1b773eeed 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -662,7 +662,7 @@ tour of all gnome components and allows the user to set them up.")
 (define-public gnome-user-share
   (package
    (name "gnome-user-share")
-   (version "3.33.1")
+   (version "3.34.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/" name "/"
@@ -670,14 +670,15 @@ tour of all gnome components and allows the user to set them up.")
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
-              "0lf790pyamdyj7180ils8vizjl8brxcg7jsm1iavfp9ay4wa8mz7"))))
+              "04r9ck9v4i0d31grbli1d4slw2d6dcsfkpaybkwbzi7wnj72l30x"))))
    (build-system meson-build-system)
    (arguments
     `(#:glib-or-gtk? #t
       #:configure-flags
-       `("-Dsystemd=false"
-         ;; Enable nautilus extension for file sharing.
-         "-Dnautilus_extension=true")))
+      `(,(string-append "-Dsystemduserunitdir="
+                        %output "/lib/systemd/user")
+        ;; Enable nautilus extension for file sharing.
+        "-Dnautilus_extension=true")))
    (native-inputs
     `(("gettext" ,gettext-minimal)
       ("glib:bin" ,glib "bin")